Back to overview
Downtime
Downtime at Serverhost
Jun 20 at 09:02am CEST
Affected services
bcnlab.org
Resolved
Jun 20 at 10:13am CEST
The issue has been resolved.
Affected services
bcnlab.org
Created
Jun 20 at 09:02am CEST
There‘s a downtime at our server host Contabo. We‘re hoping for a quick fix.
Affected services
bcnlab.org